Incoming calls issue
Incident Report for Switch
Resolved
Services have now been able for 30 minutes, as such we are closing this incident. Please accept our apologies if you were affected by this.
Posted 12 days ago. Jun 12, 2017 - 10:00 WEST
Monitoring
We are pleased to confirm that normal service was restored at 09:32.
Posted 12 days ago. Jun 12, 2017 - 09:42 WEST
Identified
Engineers have established the cause of the problem and work is ongoing to restore normal service. We apologise for the inconvenience caused to affected customers.
Posted 12 days ago. Jun 12, 2017 - 09:23 WEST
Investigating
We're aware of an issue affecting some inbound calls, and our engineers are working to restore normal service.
Posted 12 days ago. Jun 12, 2017 - 09:10 WEST