SwitchINS Portal Issue
Incident Report for Switch
Resolved
Normal service has now been restored and numbers can be managed via the SwitchINS portal again. We apologise for any inconvenience caused.
Posted 4 months ago. Sep 01, 2017 - 10:12 WEST
Investigating
Engineers are investigating an issue with our SwitchINS Portals preventing customers from viewing their number services. We are working to restore normal service as quickly as possible.
Posted 4 months ago. Sep 01, 2017 - 09:39 WEST