Service outage
Incident Report for Switch
Resolved
Normal service has been restored, we apologise for any inconvenience caused by the outage this morning.
Posted about 2 months ago. Aug 24, 2019 - 10:01 WEST
Investigating
We’re aware of an issue affecting calls to and from our telephone numbers. Engineers are investigating and we will post an update when more information is available.
Posted about 2 months ago. Aug 24, 2019 - 09:22 WEST
This incident affected: Number Services.