Telephone support unavailable
Incident Report for Switch
Resolved
Normal telephone support has been restored.
Posted 20 days ago. Nov 20, 2018 - 14:39 WET
Update
We've been able to receive calls at a reduced capacity since approximately 10am. Work to restore normal telephone support is ongoing, and we ask that you e-mail us for anything non-urgent until full capacity is restored. No customer numbers / services are affected by this issue.
Posted 20 days ago. Nov 20, 2018 - 13:00 WET
Update
We are continuing to work on a fix for this issue. No customer numbers / services are affected by this issue.
Posted 20 days ago. Nov 20, 2018 - 09:49 WET
Identified
Our inbound office telephone support lines are currently unavailable at this time, engineers are working to restore normal service but in the mean time our team are available via e-mail to support@switch-tele.com. No customer services are affected by this issue.
Posted 20 days ago. Nov 20, 2018 - 09:15 WET
This incident affected: Customer Service Team.