Incoming call issue
Incident Report for Switch
Resolved
Normal service was restored at approximately 09:25, and we apologise for the inconvenience caused by this outage.

Our engineers continue to investigate the cause, and will work with our management team to put in place any changes required to prevent a re-occurrence.
Posted about 1 year ago. Nov 29, 2017 - 09:35 WET
Investigating
We're investigating an issue causing some inbound numbers to fail when rung.

This problem is also affecting our helpdesk number, so we apologise that customers are currently unable to telephone us.

We're working to restore normal service as quickly as possible, and will post an update once more information is available.
Posted about 1 year ago. Nov 29, 2017 - 09:19 WET