Inbound sales / support telephone lines unavailable
Incident Report for Switch
Resolved
Normal service has been restored, and our Customer Service Team are now available by telephone. Please accept our apologies for any inconvenience caused.
Posted 7 months ago. Mar 20, 2019 - 10:35 WET
Identified
Our Customer Service Team are currently unable to make or receive telephone calls at this time. Engineers are working to restore service to our office.

Should you require support in the mean time please e-mail support@switch-tele.com.

There is no impact to services taken by customers.
Posted 7 months ago. Mar 20, 2019 - 10:09 WET
This incident affected: Customer Service Team.